
Acrobat XI Pro Accessible Forms and Interactive 
Documents
Create interactive forms that can be used by anyone, ensuring 
privacy and independence for all
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Adobe Acrobat XI Pro’s form creation tools make it simple to create interactive 
form fields that are accessible to users with disabilities, including those with 
visual impairments and mobility impairments. This is typically achieved by adding 
properly structured fillable fields to the PDF file, setting a tab order to control a 
logical sequence, and by adding tooltips to fields providing an accessible label and 
instructions to users of assistive technology. 

To determine if a PDF document should be an interactive form, examine the file 
for the presence of form fields, or areas in the document where users are asked 
to provide information that you would like to collect. If the form contains these 
qualities, the document can be made electronically fillable, allowing users to 
complete the form online. Many people with disabilities can fill out electronic forms 
unassisted, which is a huge advantage over print forms. An accessible electronic form 
can provide privacy, security, and independence to users with disabilities.

There are several items to be aware of when creating accessible electronic forms. 
Specifically, authors must provide:

•	 accessible and on-screen labels

•	  instructions (including field constraints and requirements)

•	  a logical tab order

•	  no keyboard traps or non-user initiated changes in focus

•	  error identification and suggestions (when known)

•	  error prevention for legal or financial information

These must be provided in a way that is available to all users, including those using 
assistive technology. For example, using the Tooltip property value, it is possible 
to add text to a check box on an RSVP that users can use to indicate their intention 
to attend an awards dinner. The tooltip could be set to “I plan to attend the awards 
dinner” which will be announced to someone who is blind or visually impaired via 
a screen reader. When form objects are used in Acrobat, the object’s type (such 
as Check Box), and state (checked or unchecked) will also be exposed to assistive 
technologies. This document describes the various types of form objects and 
provides implementation strategies for accessibility in electronic forms.

Note:  The techniques in this document are limited to the accessibility issues 
involved with creating form fields with the Acrobat XI Pro form tools. 
For a more detailed discussion of PDF forms including forms created 
with the Adobe LiveCycle Designer or the Adobe Digital Enterprise 
Platform Designer, refer to the Acrobat XI Pro online help. 
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Adobe FormsCentral (https://formscentral.acrobat.com) is another option for 
creating accessible online forms to collect responses.

Types of interactive PDF Form Fields
A PDF form created with Adobe Acrobat XI Pro’s forms editing tools can contain the following types of fields:

Text field

Allows the user to type in text, such as name, address, or phone number.

Check box

Presents yes-or-no choices for individual items. If the form contains 
multiple check boxes, the user can typically select as many or few of these 
as needed.

Radio button

Presents a group of choices from which the user can select only 
one item from the group. All radio buttons with the same name work 
together as a group.

List box

Displays a list of options the user can select. List boxes have a field 
property that lets the user Shift-click or Control-click to select multiple 
items on the list.

Combo box

Allows the user either choose an item from a pop-up menu or type in a 
value.

Button

Initiates a change on the user’s computer, such as opening a file, 
playing a sound, or submitting data to a web server. These buttons can 
be customized with images, text, and visual changes triggered by mouse 
actions. Action buttons are different from radio buttons, which represent 
data choices made by the user.

Digital signature field

Allows the user to electronically sign a PDF document with a digital 
signature.

Barcode

Encodes the input form selected fields and displays it as a visual 
pattern that can be interpreted by decoding software or hardware 
(available separately).

Automatic Field Detection using the Acrobat Form Wizard

The Form Wizard in Adobe Acrobat XI Pro can be used to create interactive forms from an 
existing electronic document (for example a Word, PDF, or Excel document) or from a paper 
form that was placed in a scanner with the resulting image opened in Acrobat. Authors can also 
create forms manually in Acrobat, or individually add form fields to an existing document using 
the form tools.
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Acrobat’s automatic form field detection will attempt to locate any labels that are adjacent to 
the form field (text, check box, etc.) and use any labels it finds as the source for the accessible 
label (the form field  tooltip in Acrobat). A form element and form objects for each field will be 
created in the Tags pane as part of this process. Examine the document carefully to verify that 
Acrobat accurately detected the fields and labeled them properly.

To make an electronic form fillable with the wizard:

1. Display the Forms Pane 

Select View Menu > Tools > Forms (The keyboard accelerator sequence 
for displaying the Forms Task Pane is Alt + V + T + F)

Figure 1. Figure 1. Create Form Command in the Forms Task Pane

2. Select the Create command 

The Keyboard Shortcut is Shift + Ctrl + 7.  
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3. The Create Form dialog is displayed 

Figure 2.  Acrobat X Pro Create or Edit Form Dialog

Acrobat XI Pro Create Form Dialog

From the Create Form Dialog, select one of the following options and then follow the on-screen 
instructions. 

Use an existing file

This option converts an existing electronic document (for example Word or 
PDF) to an interactive PDF form. To use the document that is currently on 
display, select “Next” and the “Use the current document” option. Select 
“Next” again. Acrobat automatically searches for and creates any form 
fields it detects, and places the document in Form Editing Mode. (Refer to 
“Figure 3. Adobe Acrobat XI Forms Editing Mode” on page 5).

Scan a paper form

This scans a paper form and converts it to a PDF form. The form will be 
scanned, converted to PDF and Acrobat will search for and create any 
form fields it detects. The form is placed in Form Editing Mode (Refer to 
“Figure 3. Adobe Acrobat XI Forms Editing Mode” on page 5).

Create a form from scratch or using a template

This creates an Online Form using Adobe FormsCentral. Adobe 
FormsCentral provides a simple interface to create interactive forms for 
collecting data online. FormsCentral is not addressed in this document.
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When either the “Use an Existing File” or “Scan a paper form” option is chosen, Acrobat XI Pro 
analyzes the document, adds any detected form fields, and puts the document in Forms Editing 
Mode. The document will look similar to what is shown in “Figure 3. Acrobat XI Pro Forms 
Editing Mode” below. From here, you can add, edit or delete the automatically created form 
fields.

Figure 3. Acrobat XI Pro Forms Editing Mode

During form field detection, Acrobat may have missed some fields, or created unnecessary ones. 
It may also have created fields of the wrong type. Verify the fields and field names on the form. 
Add New Field on the Forms Editing toolbar can be used to add more fields. You can also right-
click on the form to add, edit, or delete fields.

Creating a Form without the Forms Wizard

Form Editing Mode can also be enabled without using the Form Creation Wizard.

1. Select View Menu > Tools > Forms and select the Edit command under 
the Forms Tool Pane 

The Keyboard shortcut is Shift + Ctrl 7. 

2. The Add or Edit Form Fields dialog is displayed if form fields have not 
been added to this document. 

Figure 4. Acrobat XI Pro Add or Edit Form Fields Dialog

Answering “Yes” to the Add or Edit Form Fields dialog question “Do you want Acrobat to detect 
form fields for you?” causes the automatic detection of form fields prior to placing the document 
in Form Editing Mode. This is the same as running the Form Wizard. 

Acrobat will analyze the document, add detected form fields and put the PDF form in Forms 
Editing Mode. From there, you can edit the automatically created fields or add new ones. (Refer 
to “Forms Editing Mode” on page 6.)
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During form field detection, Acrobat may have missed some fields, or created unnecessary ones. 
It may also have created fields of the wrong type. Verify the fields and field names on the form. 
Add New Field on the Forms Editing toolbar can be used to add more fields. You can also right-
click on the form to add, edit, or delete fields.

Answering “No” to the Add or Edit Form Fields dialog question “Do you want Acrobat to detect 
form fields for you?” also places the document in Form Editing mode, but does not create form 
fields automatically. Form fields will have to be added manually. 

Create Form Fields Manually

If you answer “No” to “Do you want Acrobat to detect Form Fields for you?”  (Refer to “Figure 2. 
Acrobat XI Pro Create or Edit Form Dialog” on page 4), the document enters Forms Editing 
Mode without automatically creating any fields. 

To add new form fields to the PDF, select one of the options from the Add New Field drop-down 
menu that presents the eight possible Acrobat field types. 

Forms Editing Mode

In Forms Editing Mode, you can add, edit or delete any existing form object.

The Acrobat XI user interface changes when in Forms Editing Mode (Refer to “Figure 3. Adobe 
Acrobat XI Forms Editing Mode” on page 5). The Forms Editing Toolbar appears and provides 
access to the Select Object tool, the Add New Field buttons for each field type, and the Form 
Preview button. On the right hand side of the Forms Editing Toolbar, beneath the Tasks pane, 
the Add New Field, Distribute, Track, and Other Tasks commands are displayed. The Fields 
pane shows any interactive fields that are currently part of the form. You can exit this mode by 
selecting the Close Forms Editing button above the Tasks pane.

Selecting a New Form Field to Create

In Acrobat XI Pro, a form field can be created by choosing one of the form tools. For each field 
type, it is possible to set a variety of options through the form field Properties dialog box. 

The forms tools can be accessed in one of three ways:
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•	 Select “Add New Field” under the task pane.

Figure 5. Acrobat XI Add New Field Command

•	 Select one of the commands from the Forms toolbar that appears below 
the Acrobat XI Pro menubar.

Figure 6. Acrobat XI Forms Tools Icons

•	 Right click over the form to add new fields.

Figure 7. Adobe Acrobat XI Right Click Forms Dialog

Positioning and Naming the New Form Field

Once a form tool has been selected, a crosshair cursor appears, and a blue region defines the 
outline of the form object selected for placement.
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•	  On the page, click where the field is to be added. A field with a default 
size. To create a field using a custom size, drag a rectangle to set the 
dimensions of the field. 

•	  In the Field Name box, type the name of the field. Select a name that 
is relevant and descriptive to make organizing and collecting the data 
easier. This name is not shown to users of the form.

Figure 8. Field Name Box

To test the form, select the Preview button at the top of the document window. Preview lets 
you view a form the way a form recipient would, and gives the author a chance to verify the 
appearance and behavior of the form. If a form is being previewed, click the Edit Layout button 
to return to Forms Editing Mode.

Next, set the accessible name for the field. This is how the field will be announced by assistive 
technology. Other properties such as required field notation can also be set here.

Note:  If the “Keep Tool Selected” option is checked in the forms toolbar, the Field 
Name box doesn’t appear after adding a field. Each time the page is clicked, 
a new field is added to the form. To exit this mode, press the Esc key or click 
the Select Object Tool button. To modify the properties of a field, double-click 
it.

Form Field Properties

How a form field behaves is determined by settings in the Properties dialog box for that 
individual field. Properties can be set that apply formatting, determine how the form field 
information relates to other form fields, impose limitations on what the user can enter in the 
form field, trigger custom scripts, and so forth.

To modify a field’s properties, right-click it (or select and then press the Application key).

A variety of properties can be set for an Acrobat form field, depending on the form field type. 
The properties for each type of form field are selected on a series of tabs. When a property is 
changed, it is applied as soon as another property is selected or when Enter is pressed.

All form field types have a General tab, Appearance tab, and an Actions tab. Other tabs appear 
only in specific types of form fields. The Options tab appears for most form field types, but the 
options available are unique to each type of form field.

You can leave the Properties dialog box open if you want to change multiple fields at once. 

Setting Tooltips for Form Fields

The tooltip field on the General tab of the field properties dialog is the most important item for 
form fields. The content of the tooltip will be announced by screen readers as the accessible 
name of the field. This property provides the user with information and instructions about the 
field. Tooltips should be short and descriptive and should not include the type of field or text 
such as “Click to enter”.  For example, “First Name” would be a good tooltip for a first name 
field and “Sign-up Date (2 digit month / 2 digit day / 4 digit year) would be a good name for a 
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“Sign up date” field that had a required field format.  The City field for a group of shipping field 
would need to include the group name as well as the on-screen label, “Ship to City” or “Shipping 
Address City”. (Refer to “Figure 9. Adding a Tooltip to a Form Field” on page 9).

Note:  Note: The tooltip also displays text that users may find helpful in filling in the form 
field. Tooltips appear when the pointer hovers briefly over the form field. 

To set the tooltip property of a form field:

1. Ensure Forms mode is active

Activate Forms Tool > Edit 

2. Ensure that the Select Object tool is selected from the toolbar

3. Open the field properties dialog

•	 Double-click a selected form field; or

•	 Right click or select and press the applications key and select 
properties; or

•	 Select the desired field and press the shortcut keystroke (Control+I)

4. Enter a short and concise label into the tooltip field.

The tooltip should provide any group label for a group of fields along 
with the field’s label (refer to the special instructions for radio button 
groups in the next section Tooltips for Radio Buttons).

Figure 9. Adding a Tooltip to a Form Field

Tooltips for Radio Buttons

To create a radio button group, where only one field can be selected at a time, assign each field 
the same name and the same tooltip, but provide different Button Choices (values). The radio 
button choice is a field in the Options tab of the Radio Button Properties dialog.  The tooltip and 
button value will be announced to users of assistive technology for each radio button.  When the 
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same radio button name is assigned to a radio button, the tooltip field should automatically be 
populated with the tooltip text from the other radio buttons in the group. (Refer to “Figure 10. 
Identical Name and Tool Tip Value for a Radio Button Group” on page 10).

For example, create a radio button group that asks the question, “Conference Pass”.

Create four radio buttons. For each button, choose to give the button the identical name, 
“Conference_Pass.” For each radio button, the identical text appears in the Tooltip field, such as 
“Conference Pass” 

Figure 10. Setting Identical Name and Tool Tip Value for a Radio Button Group

For the button next to the label indicating “1-day Pass”, enter “1-day Pass” in the Radio Button 
Choice field under the options tab in the Radio Button Properties dialog. 

Figure 11. Setting the Radio Button Choice

Editing or Modifying an Existing Form Field

Acrobat form field properties can only be accessed in editing mode (by choosing Forms > Add 
New Field or Edit Fields). Properties for multiple form fields can be set at once. 

1. To edit multiple form fields, select the fields to edit.

Hold down control and click each field to select 

2. Right-click/Control-click one of the selected fields, and choose Properties. 

Change the properties on each of the available tabs, as needed. The 
property is changed as soon as another property is selected or Enter is 
pressed.

3. Activate the Close button or press enter to close the Properties dialog 
box. 

If form fields are selected that have different property values, some options in the Properties 
dialog box are not available. Otherwise, changes to the available options are applied to all 
selected form fields. 

Note:  To avoid accidental changes to the form field, select Locked in the lower left 
corner of the Properties dialog box before it is closed. To unlock, click the check 
box again.
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Deleting a Form Field

With the document in Forms Editing mode, click on the field to delete and do any of the 
following:

•	 Right-click and select Delete

•	 Press the Delete key.

•	 From the menu, select Edit > Delete (ALT + E, D)

Note:  To select multiple fields hold the Control/Command key and click on each 
one.

Field Actions

There are many different actions that can be associated with a form field. These include 
actions based on mouse entry, mouse exit, mouse up, mouse down, on focus, and on blur. It 
is important to note that mouse-only actions will not be keyboard accessible. All functionality 
must be keyboard-accessible without requiring the use of a mouse. The “on focus” and “on blur” 
actions are triggered when the field receives or loses focus respectively. These actions should be 
used with caution. The “on focus” action must not move focus to another field unless the field 
is not to be used, and these actions must not be used to trap the keyboard focus within certain 
fields.

The user must be able to navigate past form fields without having the keyboard focus 
trapped. This is a requirement because many keyboard-only users, including users of assistive 
technology, use the Tab or Shift+Tab keystrokes to explore the fields of a form and discover 
what options are available. For the same reason, the option “Commit value immediately” should 
be avoided for the dropdown and list fields. Users of assistive technology often use the Up and 
Down arrows to explore or navigate to items in these fields, so changing values using these 
keystrokes can prevent them from using the form properly.

Validation and Error Messages

When form validation is used to automatically validate fields, error messages must indicate what 
fields triggered the error and provide suggestions to help the user enter the correct information. 
Error suggestions are not required when they would invalidate the purpose of the form, such 
as with a quiz. But error prevention must be provided for legal or financial transactions. Error 
prevention can involve allowing the user to review or make changes, and/or checking the 
information for errors prior to submission. Typically, the Validation tab of the field properties 
dialog is used to provide feedback to the user. One accessible solution is to provide an alert that 
indicates the error and provides a suggestion. However, error-detection mechanisms should not 
restrict the ability for keyboard users to navigate among form fields.

When audio is used to indicate an error such as entering more characters into a field than are 
allowed, a visual indication must also be provided to warn users who cannot hear the audio.

Set the Tab Order

If a PDF document does not have a specified tab order, the default order is based on the 
document structure, unless the user has deselected the Tab Order option in the Accessibility 
preferences.

The tab order can be changed after the form has been created. It has the following options:
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•	 If Forms Editing mode is active, the order can be set to document 
structure (default), row, or column. 

•	 The order can also be set manually by dragging and dropping fields in the 
Fields pane. 

•	 If Forms Editing mode is not active, the order can be set in page 
properties by row or column. However, the tab order cannot be set 
manually.

To change the tab order, first select “Order Tabs Manually” from the Tab Order button on the 
Fields pane. Then fields can be dragged and dropped where appropriate within the Fields pane 
to modify the tab order (Refer to “Figure 12. Rearranging Tab Order with the Fields Pane” on 
page page 12). To assist in determining tab order, select “Show Tab Numbers” from the Tab 
Order button menu of the Fields pane (Refer to “Figure 12. Rearranging Tab Order with the Fields 
Pane” on page page 12). To see the relationship between items in the Fields pane and the 
Document pane. Note also the Order Tabs Manually and the Show Tab Numbers options are 
highlighted.

Figure 12. Rearranging Tab Order with the Fields Pane

Provide Instructions and Onscreen Labels

It is important to ensure that all form fields have instructions or labels.  Form instructions are 
typically be placed above the form, call out required fields, and provide additional information 
on completing and submitting the form. Individual form fields typically have labels above or 
to the left of the form field, with the exception of radio buttons and checkboxes, whose labels 
should appear to the right of each field. Labels should contain any formatting information, such 
as value length or date format.

Other Accessibility Considerations

In addition to making form fields accessible, other tags and properties must be set to improve 
overall accessibility. For example, the default language of the document must be specified; 
security settings must not interfere with screen readers; links must be provided in a tagged and 
keyboard accessible manner; and the document must be tagged. This is not an exhaustive list of 
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the tasks required before a form based document can be considered accessible or conformant 
to a specific accessibility standard or guideline. For a discussion on additional requirements 
including verifying conformance, refer to the Adobe® Acrobat® XI Pro Accessibility Guide: PDF 
Accessibility Repair Workflow.
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